
JFeature

Requirement Analysis & Management

1

1. 도구 개요

소 개 요구사항들을 기록하고 이들을 JUnit Test Case와 매치함으로써 프로세스를 단순화 할 수 있다

주요기능 요구사항기록, Report 생성하기

카테고리 Requirement Analysis & Management 세부카테고리 요구사항 모델링

커버리지 Requirement Analysis & Management 도구난이도 중

라이선스형태 / 비용
Common Public License 1.0 / 무료

Commercial License / 유료
사전설치도구

Eclipse 3.4이상

(상위 버전 가동 확인)

운영체제 Windows, Linux, Mac OS X, UNIX 최신버전 1.2 (2012. 10)

특징

• JUnit의 Test case 메소드와 통합

• 요구사항의 수정사항이 생겼을 때,  즉시 뷰를 제공하므로 빠른 편집이 가능

• 요구사항이 반영여부를 Coverage형태로 쉽게 확인

※ Commercial Version의 추가기능 :  요구사항들을 편집하는 확장인터페이스, 추가 리포팅 포맷,  요구사항 스펙 반출

적용회사 / 프로젝트 -

관련 도구 IBM Rational DOORS, CaliberRM , RequisitePro

제작사 Technobuff

공식 홈페이지 http://www.technobuff.net/ 
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2. 기능 요약

요구사항들을 기록하고 이들을 JUnit Test Case와 매치함으로써 프로세스를 단순화

주요기능 지원여부

요구사항 반영여부 확인 지원 (Coverage 형태)

타 플러그인 홖경 지원 지원(JUnit)

코드 추적 지원

IDE 내 별도의 편집기 제공 지원

요구사항 스펙 반출 일부 지원(Commercial Version 제공)

리포팅 기본 포맷 지원(Commercial Version 추가 제공)

Round trip engineering 지원(파일 보관형태로 지원)
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3. 도구 실행 환경

Eclipse IDE상에서 설치 및 구현이 가능

• 다양한 OS를 지원

– Windows : Windows XP / Windows 7 (32, 64-bit 모두 지원)

– Linux : 32, 64-bit 지원

– Mac OS X : 32, 64-bit 지원

– UNIX : 32, 64-bit 지원

• JDK, Eclipse 필요

– 코드 및 Eclipse플러그인 형태, 도구에 포함되어 있는 형태로 제공

JFeature

Eclipse IDE

Windows / Linux / Mac OS / UNIX

JDK (Java development kit)
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4. 도구 설치 방법
세부 목차

4.1 JFeature 다운받기

4.2 JFeature 설치하기

4.3 JFeature 설치확인하기
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4. 도구 설치 방법
4.1 JFeature 다운받기(1/2)

• http://www.technobuff.net/에서 JFeature 다운받기

– JFeature V1.2 released클릭

http://www.technobuff.net/
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4. 도구 설치 방법
4.1 JFeature 다운받기(2/2)

• 다운로드 링크 클릭 후 저장
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4. 도구 설치 방법
4.2 JFeature 설치하기

• 압축을 풀고, JFeature1.2를 Eclipse가 설치된 폴더 내의 plugins폴더에 복사

– 압축을 푼 후, net.technobuff.jfeature폴더를 해당 폴더에 복사
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4. 도구 설치 방법
4.3 JFeature 설치확인하기

• Eclipse를 실행한 후 추가된 플러그인을 확인

– File → Other → New 창에서 추가된 JFeature를 확인
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5. 도구 기능 소개
세부목차

• 5.1 JFeature 주요기능

• 5.2 요구사항 작성기능

• 5.3 예제 소개

• 5.4 요구사항 작성하기

• 5.5 요구사항 불러오기

• 5.6 요구사항 저장하기

• 5.7 Round Trip Engineering 

• 5.8 Report 생성 기능

• 5.9 JUnit을 이용하여 Test case 작성하기

• 5.10 Junit을 이용하여 Test case 연결하기

• 5.11 Report 생성하기
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5. 도구 기능 소개
5.1 JFeature 주요기능

• JFeature를 이용하여 요구사항을 작성

• JFeature를 이용하여 Junit의 Test Case 메소드와 요구사항의 연결이 가능

– 요구사항의 구현여부를 Report로 확인

[요구사항작성화면]

[요구사항Coverage Report]
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5. 도구 기능 소개
5.2 요구사항 작성기능 (1/4)

• JFeature의 기능 : 요구사항의 작성

– 요구사항 입력 : 직접 입력, 파일을 통한 입력(CSV, XML파일 읽기)

– 요구사항 저장 : JFeature로 정의된 요구사항을 파일로 저장(CSV나XML)

˃ CSV 파일과 JFeature내의 정의된 요구사항이 동일성을 유지

[JFeature 요구사항 작성예시]
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5. 도구 기능 소개
5.2 요구사항 작성기능 (2/4)

• JFeature의 기능 : 화면 구성

항 목 기 능

①Requirement ID 요구사항의 고유의 식별 번호

②Category 요구사항의 상위 분류

③Subcategory 요구사항의 하위 분류

④Title 요구사항 명칭

⑤Target release 요구사항의 타겟 배포 버젂

⑥Priority 요구사항의 구현우선순위

⑦Must Have 필수 요구사항인지 아닌지에 대한 판별 여부

⑧Test methods 요구사항과 매핑 될 테스트케이스

⑨Dependencies 요구사항과 연관된 다른 요구사항(ID)

⑩Description 요구사항의 상세한 설명

⑪Notes 기타사항
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5. 도구 기능 소개
5.2 요구사항 작성기능 (3/4)

• JFeature의 기능 : 마우스 우 클릭 메뉴

항 목 기 능

Copy Requirement(s) 요구사항 복사(한 개 이상의 요구사항)

Paste Requirement(s) 요구사항 붙여넣기

Cut Requirement(s) 선택된 요구사항의 잘라내기

Insert Requirement Below 새로운 요구사항을 아래칸에 삽입

Insert Requirement Above 새로운 요구사항을 윗칸에 삽입

Move Requirement(s) Up 요구사항을 위로 이동

Move Requirement(s) Down 요구사항을 아래로 이동
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5. 도구 기능 소개
5.2 요구사항 작성기능 (4/4)

• JFeature의 기능 : Toolbar

항 목 기 능

Add Requirement 요구사항추가

Del Requirement 선택된 요구사항 삭제

Copy Requirement 복사하기

Paste Requirement 붙여넣기

Cut Requirement 잘라내기

Move Requirement(s) Up 요구사항 목록에서 위로 이동

Move Requirement(s) Down 요구사항 목록에서 아래로 이동

Round Trip Engineering
현재 Jfeature 내에서 쓰이고 있는 요구사항파일의 변경 시 불러온 csv 파일에도 반영되게 함.

또는 csv 파일의 변경 시 Jfeature 내에서 쓰이고 있는 요구사항 파일에 반영



JFeature

Requirement Analysis & Management

7

5. 도구 기능 소개
5.3 예제 소개 (1/3)

• 도구 기능 소개 예시 : 계산기 프로젝트

– 계산기에 적용할 요구사항 (일부) : 작성된 프로젝트 홗용

– 수강 싞청 시스템의 구현 홖경

˃ 운영체제홖경

» 사용자는 PC 기반의 Windows XP 운영체제 사용

• 사칙연산 기능을 가지고 있어야 한다

- 더하기 기능이 있어야 한다

- 빼기 기능이 있어야 한다

- 곱하기 기능이 있어야 한다

- 나누기 기능이 있어야 한다

• 다양한 계산을 위해 확장 연산 기능이 필요하다

- 지정된 숫자를 올림 하는 기능이 있어야 한다

- 작거나 같은 가장 작은 정수를 double형태로 반홖할 수 있는 기능이 있어야 한다

- 지정된 숫자의 젃대값을 계산하고 반홖할 수 있는 기능이 있어야 한다
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5. 도구 기능 소개
5.3 예제 소개 (2/3)

• 예제에 사용할 클래스 생성 : Calculator

– 프로젝트선택 → 마우스 우 클릭 메뉴의 New → Class → Class이름 설정(Calculator) → Finish
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5. 도구 기능 소개
5.3 예제 소개 (3/3)

• Calculator 클래스의 코드를 작성

– 계산기의 주요 기능을 구현
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5. 도구 기능 소개
5.4 요구사항 작성하기 (1/3)

• 요구사항 작성 파일 생성 : requirements.jrq(기본설정)

– File → New → Other → JFeature → New Requirements File → Next → File name
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5. 도구 기능 소개
5.4 요구사항 작성하기 (2/3)

• 요구사항 입력

– 마우스 우 클릭 → Insert Requirement Below → 해당 항목에 요구사항 입력
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5. 도구 기능 소개
5.4 요구사항 작성하기 (3/3)

• 요구사항 입력 완료
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5. 도구 기능 소개
5.5 요구사항 불러오기 (1/4)

• 요구사항 작성파일 불러오기

– JFeature에서는 csv, xml을 읽을 수 있음

[엑셀에서 작업한 요구사항 문서]
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5. 도구 기능 소개
5.5 요구사항 불러오기 (2/4)

• 요구사항 작성파일 불러오기 : CSV파일 불러오기

– File → import → Other → Import Requirements → Next → 형식선택(CSV, XML) → Next



JFeature

Requirement Analysis & Management

15

5. 도구 기능 소개
5.5 요구사항 불러오기 (3/4)

• 요구사항 작성파일 불러오기 : 파일 지정

– Use Text delimiter → 텍스트 구분 형식 선택 → indicates a required field → 
Source field from Imported file(항목 연결) → Next

˃ Field Text delimiter

» Use comma as delimiter : 콤마(,)로 구분

» Use TAB as delimiter : 탭으로 구분

» Use other delimiter : 다른 방법으로 구분

˃ Text delimiter

» Use double quotes as delimiter : 큰 따옴표로 구분

» Use single quote as delimiter : 작은 따옴표로 구분

» Use other delimiter : 다른 방법으로 구분

˃ Preview

» Use first row as header : 처음 줄을 타이틀로 사용
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5. 도구 기능 소개
5.5 요구사항 불러오기 (4/4)

• 요구사항 작성파일 불러오기 : 파일 위치 지정
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5. 도구 기능 소개
5.6 요구사항 저장하기 (1/4)

• 요구사항 작성파일 저장하기

– CSV, XML형태로 저장이 가능
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5. 도구 기능 소개
5.6 요구사항 저장하기 (2/4)

• 요구사항 작성파일 저장하기 : Export

– File → Export 선택 → Other → Export Requirements
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5. 도구 기능 소개
5.6 요구사항 저장하기 (3/4)

• 요구사항 작성파일 저장하기 : 저장형식, 위치, 이름 설정

– 저장할 파일 형식을 선택 → 저장 위치와 파일이름을 지정
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5. 도구 기능 소개
5.6 요구사항 저장하기 (4/4)

• 요구사항 작성파일 저장하기 : 완료하기

– 내용을 확인 후 Finish
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5. 도구 기능 소개
5.7 Round Trip Engineering (1/2)

• Round Trip Engineering : import한 파일과 요구사항의 변경사항에 대한 동기화

– Import한 csv 파일에서 요구사항 변경이 일어난 경우 동일성을 유지하기 위해 사용

– Round Trip Engineering 선택 → 항목에 맞는 것을 선택 → OK
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5. 도구 기능 소개
5.7 Round Trip Engineering (2/2)

• Round Trip Engineering : 각 기능 설명

항 목 기 능

Synchronize Jfeature
requirements file

Jfeature 요구사항 파일의 변경사항을 CSV, XML파일에 변경

Synchronize external 
requirements file

CSV, XML파일을 Jfeature 요구사항 파일에 적용

Synchronize using 
Requirement ID

요구사항ID를 이용하여 비교 후 적용

Synchronize using 
Requirement Title

요구사항 제목을 이용하여 비교 후 적용

Append non-matching 
requirements

일치하지 않는 요구사항도 추가
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5. 도구 기능 소개
5.8 Report 생성기능

• Report생성 : JUnit과의 연결

– JUnit의 Test Case 메소드와 요구사항을 연결, 요구사항 반영여부를 Report로 확인 가능

˃ Junit을 이용하여 Test Case를 작성 → 정의된 요구사항과 일치하는 테스트 메소드를 연결 →
Report를 생성하여 요구사항의 만족도를 확인
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5. 도구 기능 소개
5.9 JUnit을 이용하여 Test case 작성하기 (1/6)

• 테스트하고자 하는 클래스에 대해 Test Case를 생성 : Calculator

– 테스트를 실행할 클래스 선택 → 마우스 우 클릭 메뉴의 New → JUnit Test Case

❸

❶

❷
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5. 도구 기능 소개
5.9 JUnit을 이용하여 Test case 작성하기 (2/6)

• Source folder, Package, Name, Superclass등을 그대로 두고 NEXT

– Source folder

˃ Test Case 클래스 파일이 저장되는 폴더

– Package

˃ Java의 패키지를 의미

– Name

˃ Test Case 클래스의 이름을 의미
(기본값 : 테스트 대상 클래스 명+ Test)

– Superclass

˃ Test Case 클래스가 상속받을 클래스를 의미
(기본값 : junit.framework.TestCase)
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5. 도구 기능 소개
5.9 JUnit을 이용하여 Test case 작성하기 (3/6)

• Calculator클래스 내의 테스트하고자 하는 메소드 체크 → Finish
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5. 도구 기능 소개
5.9 JUnit을 이용하여 Test case 작성하기 (4/6)

• 테스트하고자 하는 메소드의 내용을 구현

– 테스트 케이스 메소드를 구현하기 : 오른쪽의assert 메소드 이용

– Junit에서 가장 많이 이용되는 단정(assert) 메소드

˃ assertEquals(x, y) : x와y가 같으면 테스트 통과

˃ assertFalse(b) : b가 false이면 테스트 통과

˃ assertTrue(b) : b가 true이면 테스트 통과

˃ assertNull(o) : 객체o가 null이면 테스트 통과

˃ assertNotNull(o) : 객체o가 null이 아니면 테스트 통과

˃ assertSame(ox, oy) : ox와 oy가 같은 객체를 참조하고

있으면 테스트 통과

˃ assertNotSame(ox, oy) : ox와oy가 같은 객체를 참조하고

있지 않으면 통과

˃ assertfail : 테스트를 바로 실패처리
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5. 도구 기능 소개
5.9 JUnit을 이용하여 Testcase 작성하기 (5/6)

• 테스트하고자 하는 메소드의 내용을 구현

– Sum의 테스트 예시

˃ Calculator.sum(a,b)를 통해서 두수를 더한 값을 반홖

» 예시 값으로 임의의 값 사용 – a:4, b:5

» assertTrue를 통해 result가9 인지 확인
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5. 도구 기능 소개
5.9 JUnit을 이용하여 Test case 작성하기 (6/6)

• 테스트하고자 하는 메소드의 내용을 구현

– 젂체 메소드에 대해서 구현
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5. 도구 기능 소개
5.10 JUnit을 이용하여 Test case 연결하기 (1/2)

• Test Methods 연결 : 테스트 케이스 메소드와의 연결

– JUnit을 이용하여 작성한 테스트 메소드와 연결 시키고 싶은 요구사항을 선택

– Test Methods의 오른쪽에 위치한 버튼을 클릭
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5. 도구 기능 소개
5.10 JUnit을 이용하여 Test case 연결하기 (2/2)

• Test Methods 연결 : Select Test Method창

– 앞서 작성한 Test Class 찾기 → 관련 있는 Test Class Method선택 → Append to Test Method(S)

˃ Append to Test Method(s)

» TestClass Methods 추가하기

˃ Clear Test Method(s)

» 추가된 Test Class Methods 삭제하기
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5. 도구 기능 소개
5.11 Report 생성하기 (1/4)

• Report 생성 : 요구사항 파일의 연결

– 프로젝트 → Properties → JFeature → Associate Requirements File(s) → 반영할 요구사항파일 선택
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5. 도구 기능 소개
5.11 Report 생성하기 (2/4)

• Report 생성 : JUnit 테스트를 실행

– Run → Run As → JUnit
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5. 도구 기능 소개
5.11 Report 생성하기 (3/4)

• Report 생성 : Report 보기

– Windows → Show View → Other → JFeature → JFeature → OK
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5. 도구 기능 소개
5.11 Report 생성하기 (4/4)

• Report 생성 : Report 완성 결과
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6. 도구 활용 예제
세부 목차

• 6.1 예제설명

• 6.2 요구사항입력

• 6.3 프로젝트생성

• 6.4 요구사항 불러오기

• 6.5 Test Case 생성

• 6.6 Test Methods 연결

• 6.7 Report 확인
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6. 도구 활용 예제
6.1 예제 소개

• 예제 시스템 : 웹 기반 스터디 모임관리

– 스터디 방 개설

˃ 스터디 방 첫 개설자는 스터디 장이 됨 : 스터디의 카테고리, 이름, 설명, 모집 일시 등 입력

˃ 스터디 장은 스터디 방의 수정 및 삭제 가능

– 생선된 스터디 방에 가입 가능

˃ 사용자가 생성된 스터디를 검색하고, 원하는 스터디에 가입싞청 / 싞청취소가 가능

– 스터디 일정 관리

˃ 스터디의 일정을 등록, 수정, 삭제할 수 있다

– 스터디 방의 게시판을 관리

˃ 스터디 장이 스터디 방의 게시판을 생성 / 이름 설정 / 수정 / 삭제 가능

– 스터디 장이 스터디 방의 가입된 스터디 원들을 관리할 수 있다.

˃ 스터디 장은 스터디 클럽의 참석률이 낮은 회원을 강제 퇴출 가능

˃ 스터디 클럽의 회원 정보의 조회가 가능

˃ 스터디원이 올릮 과제를 확인

– 스터디원이 스터디 방을 이용할 수 있다

˃ 스터디 원이 다른 스터디 회원 정보의 조회가 가능

˃ 스터디 원이 자싞 출석률의 확인 가능

˃ 스터디 원이 과제제출 가능
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6. 도구 활용 예제
6.2 요구사항입력 (1/2)

• 요구사항 입력 : 엑셀에 정리하기



JFeature

Requirement Analysis & Management

4

6. 도구 활용 예제
6.2 요구사항입력 (2/2)

• 요구사항 입력 : 엑셀에 정리 후 CSV파일로 저장

– 엑셀에서 파일형식 → CSV파일로 저장
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6. 도구 활용 예제
6.3 프로젝트 생성

• 프로젝트생성하기

– File → New → Project를 이용하여 Java Project를 생성
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6. 도구 활용 예제
6.4 요구사항 불러오기 (1/2)

• 요구사항 불러오기 : CSV파일 읽기

– 프로젝트 선택 후 마우스 우 클릭 → Import → CSV파일 열기 → Use Text delimiter → 
텍스트 구분 형식 선택 → Requirement fields 목록 매칭
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6. 도구 활용 예제
6.4 요구사항 불러오기 (2/2)

• 요구사항 불러오기 : 결과

– CSV파일을 읽어온 결과



JFeature

Requirement Analysis & Management

8

6. 도구 활용 예제
6.5 Test Case 생성

• Test Case 생성

– 회원 로그인에 대한 Test Case를 작성
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6. 도구 활용 예제
6.6 TestMethods 연결

• Test Methods 연결하기

– 요구사항과 매칭되는 Test Class Methods를 연결
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6. 도구 활용 예제
6.7 Report 확인

• Requirement Coverage Report 결과
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7. FAQ

질문1) 현재 Eclipse 4.2까지 나와있는데, JFeature1.2의 버전문제는 없나요?

답변1 : 1.2 버전 이후로는 진행된 릴리즈가 없습니다만, 1.2버전은 3.4버전에 최적화 되
어 있습니다. 현재 테스트 결과로는 4.2 버전에서 까지 이상 없는 것으로 확인
되고 있으나, 이클립스 특성상 3.4버전에서 가동하는 것을 추천합니다.

질문2) JUnit이외에 다른 플러그인들과는 연동이 되지 않습니까?

답변2 : 네. Jfeature는 JUnit Test Case 이외의 다른 플러그인들과는 연동이 되지 않습니
다.
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8. 도구 평가

• 홗용성
– 요구사항을 JUnit과 연동하여 사용하기 때문에 쉽고 빠르고 효과적으로 사용

• 범용성
– JUnit이 필수이나, 현재 다른 테스트 도구와는 연동기능 없음

• 호홖성
– 자바를 지원하는 모든 도구에 호홖

– Eclipse 3.4버전에 최적화 되어있지만, 현재(4.2)버전에서도 이상 없이 가동

• 성 능
– 빠른 작동성능, 도구에 같이 로드 되어도 성능상 문제 없음

• 기 타
– 대부분 JAVA IDE에 탑재되어있는 JUnit을 홗용하므로 테스팅 기반 통합이 용이

– 코드를 개발하면서 요구사항확인이 편리

도구평가 의견

 표준 JUnit 단위 테스팅을 기반으로 통합이 가능

 개발자들이 코드를 개발하면서 요구사항을 확인하고 쉽게 적용시킬 수 있도록

편리한 편집과 뷰를 제공

 사용방법이 편리하며, 간단
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9. 용어 정리

본 매뉴얼에서 사용하고 있는 용어의 정리

TestCase
특정한 프로그램부분 및 경로를 실행해 보거나 특정한 요구사항에 준수
하는지를 확인하기 위해 개발된 입력 값, 실행조건, 그리고 예상된 결과로
이루어져 있는 하나의 테스트 세트

CSV
각 항목이나 내용마다 쉼표(comma)로 구분하여 기록 CSV형식의 파일은
텍스트 파일로 보존하여 문서처리기나 편집기에서 열람 · 편집 가능

XML

기존의 HTML과는 다른 마크업 언어로 보다 홈페이지 구축기능, 검색기능
등에 유리하며, 클라이언트시스템의 복잡한 데이터처리를 쉽게 할 수 있
다는 장점을 가짐. 또한 인터넷 사용자가 웹에 추가할 내용을 작성, 관리
하기에 쉽게 되어 널리 사용


